
 

HOW TO CREATE A REALISTIC 
SKY WITH THE ENVSKY TEXTURE By S. Christov 

Maya Complete 
Rendering 

The environment sky 
is a powerful 
procedural texture 
that you can quickly 
and easily add to 
your scene to give 
the appearance of a 
sky overhead.  

In this first part of a three part lesson you will learn how 
to create an environment sky and set attributes that will 
create a realistic looking sky.  

In the next lesson - How to create realistic shadows 
using envSky - you will learn how to achieve realistic 
shadows using the position of the sun on the envSky 
texture. In the final lesson you will learn how to "grow" a 
tree in Paint Effects from a simple black brush stroke - 
How to create a tree using Paint Effects. 

After these three lessons, you will be able to combine 
these elements to produce an animation similar to the 
one above where you create a time lapse animation of a 
sunset.  

Play Movie [~800k]

You will first need to 
create a new camera 
and then attach an 
image plane to it.  

Create a new camera 
by selecting Create > 
Camera. 

Translate the camera 2 units in the Y axis and 6 
in the Z axis.  

  STEP ONE
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Open the Attribute Editor for the new camera, and 
open the Environment section. Click on the 
Create button next to Image Plane. The Attribute 
Editor window will now switch to the Attribute 
Editor for the Image Plane.  
Open the Placement section and click on Fit to 
Resolution Gate. This will ensure that your image 
plane will fill the entire rendered scene.  

While you are still in 
the Attribute Editor 
for the Image Plane, 
Click on the Map 

 button next to 
Texture and map an 
envSky.  

The envSky node is 
located in the 
Environment 
Textures section of 
the Create Render 
Node window.  

  STEP TWO

You will now set the 
colors for your 
environment. In the 
Attribute Editor for 
the envSky, Set the 
following attributes: 

Sun 
Brightness to 
1, 1, 0.5  
Halo Brightness to 0.35, 0.36, 0.5  
Under Atmospheric Settings, Set the Sky 
Brightness to 0.56, 0.617, 1.0  

To change any of the color values, select the color icon 
next to the attribute. This will open the Color Chooser. 

  STEP THREE
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Make sure you are using the RGB values by checking 
the RGB box near the bottom of the window. You can 
then type the values in manually.  

NOTE: To open the Attribute Editor for the envSky, 
select the 3D Icon for the envSky texture and open the 
Attribute Editor. Click the Goto Output Selection 
Button  at the top right side. This will take you to 
the envSky Attribute Editor.  

Open the Floor 
Attributes section for 
the envSky, Map the 
color of the floor to a 
2D Fractal texture.  

Change the Color 
Gain to a Dark 
Green and the Color 
Offset to a Dark 
Brown. This will be 
your floor.  

Select Camera 1 and 
Select > Panels > 
Look Through 
Selected. Turn on 
the Resolution Gate 
by selecting View > Camera Settings > Resolution 
Gate.  

Render this view by selecting Render > Render into 
New Window. 

  STEP FOUR

When you render 
with the floor turned 
on, you may 
encounter a bright 
red surface for part 
of the floor. This is 
due to the fact that 
your camera is 
rendering a point that is below the Floor Altitude. You 

  STEP FIVE
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can fix this by either lowering the Floor Altitude, raising 
the look at point of the camera, or scaling the 3D icon. 
In this case we are going to scale the icon. 

Select the envSky icon in the perspective view 
window. In the Channel Box set the Scale X Y Z to 5. 

Re-Render your 
scene. You should 
now have a floor 
that extends to a 
vanishing point.  

You are now ready 
to add clouds to the 
scene. Open the 
Cloud Attributes 
section in the 
Attribute Editor for 
the envSky. Click the box next to Use Texture to turn it 
on.  

Click the Map button next to Cloud Texture. This will 
open the Create Render Node window. Select a Cloud
Texture.  

  STEP SIX

Preview your sky by 
rendering the 
Camera 1 view. 

You will notice clouds 
in the scene but they 
are faint. You can 
make them more 
pronounced by setting the density. Set the Density 
under the Cloud Attribute of the envSky to 2.0.  

Render your scene. 
You should now see 

  STEP SEVEN
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clouds in the sky. 

Switch to your persp 
camera. If you take a 
close look at the 3D icon 
for the envSky, you will 
notice that there is a point 
that represents the sun. By adjusting the Elevation, 
Azimuth and Size, you will change the position and size 
of this point.  

Set the Elevation to 90 degrees. This will position the 
sun directly in the middle of the sky and also produce 
the brightest light. Notice on the 3D icon, that the sun 
icon has moved directly to the top middle of your icon. 

Render the scene. 
You should now see a 
bright blue sky. 

  STEP EIGHT

You will now position 
the sun so that it 
appears in your scene. 
To do this you will need 
to align the line that 
represents the sun to 
intersect a point in your image plane. Make the 
following changes to position and size of the sun so 
that it will be seen in the image plane. 

  STEP NINE
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Elevation to 10  
Azimuth to 0 
Size to 3.0  

If you imagine the line on 
the 3D icon representing 
the sun going off to 
infinity, it will intersect the 
image plane which in turn 
will render the sun in your 
image. You may need to 
switch to your persp view 
and zoom out to see this.  

Render the Scene. Notice how the color of the sky 
changes in relation to the elevation of the sun. At an 
elevation of 90, you get an image that has the 
brightest possible sky. At a lower elevation your sky 
begins to change to a darker color. However the 
appearance of the sun does not seem quite bright 
enough. In this case we will increase the total 
brightness to get a nice sunset.  

Increase the Total Brightness to 3.0.  

Render the Scene. You should now have a decent 
looking sunset. 

Save your File. 

You have now setup 
an envSky texture 
that will produce an 
environment 
complete with sun 
and clouds. There 
are many attributes 
to experiment with 
on this texture. You can achieve some interesting 
results by adjusting the some of the Atmospheric and 
Cloud attributes.  

In the next lesson you will use this file and learn how-to 
achieve realistic shadows based on the position of the 
sun.  

  CONCLUSION
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HOW TO CREATE REALISTIC 
SHADOWS WITH ENVSKY By S. Christov 

Maya Complete 
Rendering 

This lesson is a 
continuation of How 
to create a realistic 
sky using envSky. 

In this lesson you 
will use your 
environment sky 
texture from the last 
lesson and link a directional light to the elevation and 
azimuth that will simulate the shadows cast when you 
animate the position of the sun. 

In the final lesson you will learn how to "grow" a tree in 
Paint Effects from a simple black brush stroke - How to 
create a tree using Paint Effects. 

Play Movie [~800k]

Open Env_Sky.ma file 
that you saved from the 
last lesson. 

In the Attribute Editor for 
the envSky, Set the 
Elevation and Azimuth 
to 0. Set the Total Brightness to 1.0. 

Providing you have not moved or rotated the 3D icon 
the sun position should be lined up along the Z axis. 

  STEP ONE

You are now ready to 
create a directional light 
and link it into the 
attributes of the envSky 

  STEP TWO

Page 1 of 6

3/18/2002file://K:\maya%20tutorials\Env%20Sky%20pt2_shadows.htm



texture.  

Create a Directional 
Light.  

You will want this light to 
cast shadows so you will 
need to turn on 
shadows. Open the Attribute Editor for the light. In the 
shadows section, Click the box next to the Use Depth 
Map Shadows. 

You will notice that the light is pointing at the sun rather 
than away from it. Rotate the light 180 in the Y axis. 
This will align it properly.  

With the light 
selected, Group it to itself by selecting Edit > Group. 

In the Attribute Editor Rename this node lightLinker. 

  STEP THREE

Open the 
Hypergraph 
window and 
holding the shift key, Select the lightLinker node and 
the place3dTexture node for envSky.  

Select Graph > Up and Downstream Connections.  

With the Middle Mouse Button, Drag the EnvSky1 
node onto the lightLinker node.  

In the Connection Window that opens, click on 
Elevation on the left side, then click on Rotate X on 
the right. This connects the Elevation on the envSky 
node to the Rotate X attributes on the lightLinker node.

Close the Connection Editor window. 

  STEP FOUR

  STEP FIVE
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In the 
Hypergraph window, click on Rendering > Create 
Render Node window. . . 

If you were to directly connect the azimuth to the 
directional light you would find that as you adjust the 
azimuth your light would rotate in the opposite 
direction. In this case a reverse node will be used to 
correct this.  

In the Create Render Node window, click on the 
Utilities tab. Under General Utilities section, Create a 
Reverse node.  

In the Hypergraph 
window, Drag with 
the Middle Mouse Button, the envSky1 node onto the 
Reverse node. This will open the Connection Editor. 

Connect the Azimuth on the left side, with the Input X 
on the right side.  

In Hypergraph, Drag the Reverse node onto the 
lightLinker node. In the Connection Editor, Connect 
Output X to the Rotate Y. 

Test your light connection by opening the Attribute 
Editor for the envSky node, and changing the 
Elevation and Azimuth settings.  

You should now notice that the directional light will 
rotate along with the Elevation and Azimuth.  

  STEP SIX

Create a plane, by 
selecting Create > 
NURBS Primitive 
> Plane.  

Because you are 
unable to cast 
shadows on the floor of the envSky, you will need to 

  STEP SEVEN
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turn it off. Open the Attribute Editor and Uncheck the 
box next to Has Floor. Scale the Plane out to roughly 
35 units.  

Create a new Lambert material in the Hypershade, 
Change the color of the new Lambert to white. This will 
make it easier to see the shadow. 

Assign this material to the Plane. 

Select Create > NURBS Primitive > Sphere. Move the 
sphere up in the Y axis. This will be your shadow 
casting object and will make it easier to see where the 
shadow will fall. Assign a new material to the sphere. 
Move the sphere so that it sits just above the floor.  

Create an Ambient Light. Move the light to a point in 
front of the cone. Set the Intensity to 0.5. 

Position Camera1 
in your scene. The 
most effective 
positioning of the 
camera when 
using an envSky 
is to point the 
camera slightly 
towards the sky.  

Move the camera away from the cone to see a good 
portion of the floor in front of it. This is where your 
shadow will be cast. Make sure that the camera is not 
positioned past the edge of the plane.  

  STEP EIGHT

You are now are going to 
animate the clouds.  

Select the 3D icon for the 
cloud. Move it 6 units in 
the Z axis. Set a key at 
time 1 by selecting 
Translate Z in the 
channel box and with the right mouse button select 

  STEP NINE
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Key Selected from the drop down menu. Set another 
key for the Rotate X attribute value at time 1.  

Move the time slider to time 100. Change the 
Translate Z of the icon to 0 and set a key. Change 
the Rotate X to 60 and set another key.  

You are now ready 
to animate the 
setting of the sun.  

Move your time 
slider to 1. Set the 
elevation attribute 
on the envSky to 75 and click the attribute with your 
right mouse button and select Set Key.  

Change the time slider to 100. Change the elevation to 
0 and Set a Key.  

Press Play, you should now see the envSky icon 
animate the elevation over time.  

Set up your Render Globals to render out 100 frames 
from Camera1. Save your file and then render out the 
frames.  

  STEP TEN

You have now 
constructed an 
envSky that will cast 
accurate shadows 
according to the 
position of the sun. 
Click on the image 
to get a "time lapse" 
animation of a 
setting sun. Pay 
attention to the length and direction of the shadow as 
the sun sets.  

You can further enhance the animation by keying the 
size and total brightness of your sun as it sets to 
produce a more dramatic sunset. You may also want to 
key the ambient light slowly to zero intensity at around 

Play Movie[~800k]

  CONCLUSION
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HOW TO CREATE A TREE 
IN PAINT FX By S. Christov 

Maya Complete 
Paint Effects 

In this lesson you 
will create a tree in 
Paint Effects starting 
from a simple black 
brush stroke.  

While this approach 
is somewhat drastic 
it will help you form 
a good understanding of the attributes that make up 
Paint Effects.  

This article assumes you have Paint Effects loaded into 
Maya. Please see the Maya help menu on how to install 
Paint Effects if you have not already done so.  

This lesson is the third of a three part lesson. You may 
want to complete parts one "How to create a realistic 
sky using EnvSky" and two "How to create realistic 
shadows using EnvSky" before you start this lesson. 

Play Movie [~800k]

Download and open 
the scene 
Env_sky_shadow.ma. 
If you have 
completed the 
previous lessons, 
you can use your 
last saved scene file.  

Delete the sphere.  

Select the lights, 3D env_sky icon, and the 3D texture 
icon for the cloud.  

Select Display > Hide > Hide Selection. This will 

  STEP ONE
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unclutter the scene so we can concentrate on the Paint 
Effects stroke. 

Switch to the Persp 
window. Select the 
plane and select the 
Paint Effects > 
Make Paintable.  

Open the Visor by 
selecting Windows > Visor. Scroll to the bottom and 
open the section marked Brushes. This will give you 
access to the Paint Effects preset brushes.  

Open the Pens and select the simpleLine brush.  

In your perspective window, Paint a small stroke near 
the origin.  

  STEP TWO

With the stroke still 
selected, open the 
Attribute Editor. 
Open the tab 
simpleLine1. Your 
first step is to add 
tubes to the brush.  

Open the tubes section and Click beside Tubes and 
then Tube Completion.  

Open the Tubes > Creation section. Change the 
Tubes Per Step to 0.1 and the Tube Rand attribute to 
0. Also change the Length Min to 0.8, and the Length 
Max to 0.9.  

You will also see some attributes called Tube Width1 
and 2. These set the width for the base of the tube and 
the tip of the tube respectively. Change the Tube 
Width1 to 0.12 and Tube Width2 to 0.09. There are 
settings for randomness and bias for multiple tubes 
across the same stroke but because we are only 
creating one tube, we can ignore these settings.  

  STEP THREE
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Change the number of Segments to 40. This will 
increase the number of segments that are used to 
create the tube.  

The Elevation attribute dictates the lean on the tube. 
Where 0 is the tube lying flat against the curve and 1 
standing straight up. Since you want the tree to stand 
straight up, set the Elevation Min and Max to 1.0.  

NOTE: You may notice that your tube is still lying flat 
against the curve despite changing the elevation 
attribute. You can fix this in the attribute editor. Open 
Behavior > Forces. Change the Path Follow to 0.0. 

Now that you have 
the basic shape of 
the trunk you are 
now ready to shade 
it. 

Open the Shading 
section in the Attribute Editor. Click on the color 
swatch next to Color1. In the color chooser change 
the RGB values to 0.64, 0.52, 0.41.  

Open the Tube Shading section. Click on the color 
swatch next to Color2. Set the RGB values to 1.0, 
0.85, 0.83.  

You have now set the colors for the trunk of your tree. 
If you render now you will see that it will render out in 
one uniform color. By adding a simple ramp texture to 
the tube you can simulate bark. 

Open the Texturing section. Click on the icon next to 
Map Color. We are going to map a V Ramp to the 
trunk of the color to give the appearance of bark.  

From the drop down menu beside Texture Type, 
Select V Ramp. Set the following attributes: 

Texture2 Color to RGB 0.54, 0.49, 0.44  
Repeat U to 6.0  
Repeat V to 2.2  
Blur Mult to .26  
Smear to 0.203  

  STEP FOUR
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Smear V to 0.61  

You can preview the progress this far by pressing the 
hotkey "8" while in the persp window to switch to the 
paint effects preview render window. In the menu 
select Stroke Refresh > Rendered. However it will 
take longer to refresh with each change.  

NOTE: When you render, depending on the length of 
your original stroke, you may have more than one tube 
attached to your stroke. One way to solve this is to 
lower the Tubes per Step attribute in the Tubes > 
Creation section.  

In Paint Effects you 
have the option to 
Illuminate the tree 
with simulated or 
real lights.  

Open the 
Illumination section, Check the box next to Illuminated. 
This will use real lights from your scene on your paint 
effects tree.  

We are also going to add some specular qualities to 
the tree to give it some highlights. Set Specular to 
0.15. 

  STEP FIVE

Now that we have 
the trunk, we are 
ready to add some 
branches. Open the 
Tubes Growth 
section and click 
next to Branches to 
add them to the trunk.  

Open the Branches section. Increase the Split Max 
Depth to 7. This increases the number of times the 
branch will split up.  

Increase the Branch Dropout to 0.02.  

  STEP SIX
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The next set of values control different attributes for the 
split on the branch including Randomness, Angle of 
split, Twist. Feel free to experiment with these values 
and come up with your own style of tree or you can set 
the following values: 

Split Rand to .017  
Split Angle to 26.3  
Split Twist to 0.32  
Split Size Decay to 0.67  
Split Bias to 0.19  

Click on the box 
next to Twigs to turn 
them on. Open the 
twigs section.  

Set the Num Twig 
Clusters to 8.0 and 
set the Twig Dropout to 0.439.  

Then next attribute set length, width,angle and twist. 
Again feel free to experiment with the settings to get 
your own tree or set the following attributes: 

Twig Length to 0.08  
Twig Base Width to 0.7  
Twig Tip Width to 0.15  
Twig Angle1 to 52.5  
Twig Angle2 to 54.0  
Twig Twist to 
0.512  

Keep in mind that your 
twigs will decide the 
placement of leaves. 
So these settings can 
have a pretty dramatic 
effect down the line. 
For example increasing the number of Twig Clusters 
will result in more leaves on your final tree.  

  STEP SEVEN

  STEP EIGHT
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You will now add 
some leaves to the 
tree to complete the 
look. Click the box 
next to Leaves. Set 
the following 
attributes: 

Leaves in 
Cluster to 5.0  
Num Leaf Clusters to 4.0  
Leaf Dropout to 0.154  
Leaf Length to 0.04  
Leaf Base Width to 0.035  
Leaf Tip Width to 0.01  
Leaf Start to 0.9  
Leaf Twist to 
0.5  
Leaf 
Translucence 
to 0.561  
Leaf Sat Rand 
to 0.033  
Leaf Val Rand 
to 0.114  

Check the box next to Terminal Leaf. This will place a 
leaf at the end of each twig. 

If you render your 
image at this point 
you should have a 
basic looking tree. 
You are now ready 
to add various 
other attributes to 
further enhance 
your tree. 

In the Attribute Editor open the Behavior > Forces 
section. Set the Gravity slider to 0.05. You will notice 
that the branches and leaves spread out as if the 
weight of the leaves was pulling the branches down.  

  STEP NINE

  STEP TEN
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You are now ready 
to add some 
animation to the 
tree to simulate it 
swaying in the wind. 

Open the 
Behaviour then the Turbulence section. Set the 
Turbulence Type to Grass Wind. Set Turbulence 
Interpolation to Smooth over Time and Space.  

Because we are going to use this tree with a time lapse 
sunset, you will want the tree to behave with tight 
motion in the tree trunk and branches but you do want 
the the leaves to give the impression of some quick 
fluttering in the wind. Set the following values: 

Turbulence to 0.02  
Turbulence Frequency to 0.005  
Turbulence Speed to 1.0  

Set the Time Slider to 100. Press Play. Switch to the 
Perspective window. The wireframe will give you an 
indication of the general motion of the tree. 

You will now save 
your brush to the 
visor so you can 
access it in the 
future. With the tree 
selected, go to 
Paint Effects > Get 
Settings from 
Selected Stroke. 
This will apply your 
tree to the template 
brush.  

Now select Paint Effects > Save Brush Preset. . . 

Set the Label and Overlay Label to Mytree.  

Save it To Visor and set the Visor Directory to Trees. 

Click on Grab Icon and drag around your tree in the 
render view to make an icon for you brush.  

    STEP ELEVEN 
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Click Save Brush Preset.  

Select Panels > 
Perspective > 
Camera 1.  

Position your tree in 
the frame by 
selecting the stroke 
and moving it with 
the manipulator. Add a texture to the ground plane.  

Do some test renders at different frames to make sure 
you are happy with the framing and lighting. When you 
are satisfied with the results, set the render globals to 
render the animation for 100 frames from Camera1.  

  STEP TWELVE

You have now 
assembled a 
complete scene 
similar to the one 
above. By this point 
you have learned 
how to create and 
use an environment 
sky, add a light to it 
to simulate realistic 
shadows based on the sun position, and made your 
own tree in paint effects.  

Enhance your scene by sculpting the floor surface with 
Artisan to make some nice rolling hills and adding some 
grass strokes to it.  

Download the completed scene file. [~100k] 

Play Movie[~800k]

  CONCLUSION
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